Please sign in to get the most from this site.

Adding Anchors to Emails and Landing Pages

8
Follow

Comments

8 comments

  • Avatar
    Rachel Camaerei

    I don't have the anchor drop-down option in my link button. Is this new? https://www.screencast.com/t/9OF1XFJj

    0
    Comment actions Permalink
  • Avatar
    Kailey Wilderman

    I'm having the same issue where I am not seeing the anchor drop-down option under the insert/edit link. What do we need to do to see this?

    0
    Comment actions Permalink
  • Avatar
    Chris Apgar

    Hi Rachel Camaerei and Kailey Wilderman - thank you so much for letting us know. What I believe is happening is that the editor is not adding the anchor if it's on a new line by itself.

    To test my theory, would you please try typing some text and then adding your anchor directly beside it? You should then see the anchor symbol appear (which it probably was not when you were trying this before) and then the anchor section should appear in the link options.
    I'll share this bug with our product team to get it fixed, but if that is your issue then hopefully you can temporarily resolve it by typing the text, adding your anchor, then removing the text again.

    0
    Comment actions Permalink
  • Avatar
    Kailey Wilderman

    Hello Chris - Actually, the anchor is showing up next to the text when I add the anchor beside it. It's just that the drop down is not appearing in the link option:

    But still no drop down:

    0
    Comment actions Permalink
  • Avatar
    Rachel Camaerei

    Thanks for responding Chris.

    When I initially tested the anchor, it was not on a line by itself but before the text I wanted to anchor and was appearing as shown in Kailey's example above. By putting the anchor after the text, this populates the drop down. Must only be able to use an anchor if adding after text and not before. 

    Thanks,

     

    0
    Comment actions Permalink
  • Avatar
    Chris Apgar

    Thank you both for the additional information! Our team is working on a solution to this.

    0
    Comment actions Permalink
  • Avatar
    Kailey Wilderman

    Hi Chris - I just tried to add the anchor after the text (based on Rachel's response) and then tried to link and unfortunately it is still not populating the drop down box for me. I'm not sure why...

    Kind regards,

     

    0
    Comment actions Permalink
  • Avatar
    Chris Apgar

    Thanks Kailey – sorry this is still going on. I've opened a support case for you, if you could please provide any info there for how to replicate this issue (which specific piece of content you're in, for example) our team can take a closer look.

    In the meantime, one more thing you can try: in the URL for your link, type in "#" followed by the name/ID of the anchor. This should add a link to the anchor without having to use that dropdown.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Looking for more help?